Installer compatible with FSX-SE

Due to high demand of users to install the NL2000 version 4 in the Steam version FSX SE the installer is now compatible with both FSX and FSX SE. The new version is 4.0.66.

The new installer can be downloaded on our download page.

The new version is also prepared to work with the Lockheed Martin Prepar3D, version 2.5. For these users we opened a new forum to share found issues.

Future updates of other parts NL2000 will also need this installer. Please uninstall the older version first and then to install this installer 4.0.66.

This post is also available in: nlNederlands (Dutch)

Anonymous

Mark

Site admin of NL-2000.com

You may also like...