Installer unable to install libraries etc.

Ask questions about installing NL2000 version 4.0 here

Moderator: NL2000 Development Team

Post Reply
User avatar
johnfromoz
Newbie
Newbie
Posts: 8
Joined: Thu Jan 01, 1970 2:00 am
Contact:

Installer unable to install libraries etc.

Post by johnfromoz » Sun Nov 06, 2016 8:59 am

I have used the fairly recently downloaded Installer v4.0.74 to install the photosceneries, airports, libraries etc. I am running FSX with Acceleration (the boxed FSX, not Steam) in Windows 8.1.

My FSX is in the default location on C drive. I installed NL2000 to the F: drive, following the manual advice that "The preferred location a different physical disk, than the one containing FSX or Windows7."

I encountered several problems.

(1)When trying to install the libraries I received a report that it was unable to modify the FS Autogen\default.xml file. A popup window reported "Access to the path 'C:\Program Files(x86)\Microsoft Games\Microsoft Flight Simulator X\\Effects\fx_avira.fx' is denied" (NB - the double \\ is not a typographic error, that is how it showed in the popup).

(2)Loading FSX results in reports for Local Scenery Directory Not Found for nl2k_v4_3D. I find that folder contains nothing but two text files, apparently just copyright statements.

(3) FSX also reported no Local Scenery Directory for nl2k_v4_libraries. That folder contained only two text documents and no scenery or texture subfolders. The raw nl2 file for the libraries shows as 345,608 kb in size.

(3) Similarly FSX reported no Local Scenery Directory for nl2k_v4_Heliports. That, too contained only two text documents and no scenery or texture subfolders.

(4) The installer has alarm tags (the yellow triangle with a (!) inside) for
- nl2k_v4_3D
- NL2000 v4.0 Fotoscenery object excludes
but no alarms for the missing libraries, nor for any of the photosceneries or airfields.

Accepting the reports of absent sceneries directories, I loaded a flight from Texel. The airport was quite beautiful. Autogen seemed sparse, just isolated trees. I believe there is a landmark windmil at the south end of the island, but didn't see one. Perhaps it really is that sparse but I believe the uninstalled scenery library includes windmills.

I moved to the dockyard area north of Amsterdam, and saw only a static or AI boat, very good photoscenery, EHAM in the distance, but absolutely no 3D objects in or around the city, presumably because of the absent library. FSX then crashed.

I can find no solution to these in the forum, at least in the English portion. I have waited a couple of years for a computer upgrade and decent download speeds in my area, so I could see NL2000 running in FSX. Please can you offer some solutions?

arnoj
Posting Freak
Posting Freak
Posts: 294
Joined: Thu Jan 01, 1970 2:00 am

Post by arnoj » Sun Nov 06, 2016 10:53 am

The first question back is allways. Did you install NL2000 with administrator rights? Like point 4 ( Installation) ad page 7. If not, then I can think that will be the reason for the most of the problems.

User avatar
johnfromoz
Newbie
Newbie
Posts: 8
Joined: Thu Jan 01, 1970 2:00 am
Contact:

Post by johnfromoz » Mon Nov 07, 2016 6:34 am

The Win 8.1 control panel shows me as "Local Account Administrator" so I assumed yes, install as admin was default.
I have reread the manual and at p.18 I see I needed to right click the icon to start the installer. That wasn't obvious to me but it was certainly there in the manual. I have got everything installed, I think, and will try the same flights again.
Thanks for your quick reply which pointed me to the answer.

EDIT: It all seems to work now. A quick tour around Texel, and a flight from Lelystad over Amsterdam both went well. I think the FSX crashes were due to me moving the aircraft in map mode, as it happened each time I tried and I hear it's an FSX thing. I still see the yellow alert triangles in the installer for the main 3D and object excludes but as yet have to notice any problems.
Beautiful scenery. A small donation as thank you has been sent. :D

User avatar
ph-lcs
NL2000 Development Team
NL2000 Development Team
Posts: 126
Joined: Thu Jan 01, 1970 2:00 am
Location: Dordrecht

Post by ph-lcs » Mon Nov 07, 2016 7:41 pm

On behalf of the NL2000 Development team I would like to thank you for your donation.

Also please keep a sharp lookout the next couple of weeks, since there will be a new version 4.09.

http://www.nl-2000.com/nuke/modules.php ... =0&thold=0

best regards,
Jos (PH-LCS)
NL2000 Development Team

CapitanPhilips
Newbie
Newbie
Posts: 4
Joined: Sun Oct 15, 2017 11:30 am

Installer unable to install libraries etc.

Post by CapitanPhilips » Sat Oct 21, 2017 1:34 pm

I have downloaded letest installer, latest libraries and latest eham scenery. I installed this installer and than i wanted to add packages. First I wanted to install libraries but when istallation was comleted the message came out:SystemUnauthorizeAccesException to string C/Program Data/Microsoft/FSX/Scenery.CFG.nl2 and than more text. After I run FSX scenery didnt work. It was normal schippol defalut fsx textures. I have FSX Steam edition installed on drive B (Program Files and Program Files x86 are located on disk C) . Please help Should I install my FSX on disk C in Program Files or Program Files x86?

User avatar
Mark Arends
Site Admin
Site Admin
Posts: 732
Joined: Thu Jan 01, 1970 2:00 am
Location: Rotterdam
Contact:

Re: Installer unable to install libraries etc.

Post by Mark Arends » Tue Oct 24, 2017 4:23 pm

The first question back is allways. Did you install NL2000 with administrator rights? Like point 4 ( Installation) ad page 7. If not, then I can think that will be the reason for the most of the problems.

CapitanPhilips
Newbie
Newbie
Posts: 4
Joined: Sun Oct 15, 2017 11:30 am

Re: Installer unable to install libraries etc.

Post by CapitanPhilips » Sun Nov 05, 2017 12:26 pm

I installed all things with the administaror rights on the administrator account on my computer and it not worked. If I try to install it manualy on FSX did it work?

ridgeandgable
Newbie
Newbie
Posts: 3
Joined: Sun Apr 26, 2020 3:26 pm

Re: Installer unable to install libraries etc.

Post by ridgeandgable » Sun Apr 26, 2020 3:49 pm

I'm using p3d V4.5 and latest installer and when I install library with admin rights (right click, run as admin) I get the same error

"Unable to modify fs\Autogen\default.xml

User avatar
phjoop
NL2000 Development Team
NL2000 Development Team
Posts: 1402
Joined: Thu Jan 01, 1970 2:00 am
Location: Leek

Re: Installer unable to install libraries etc.

Post by phjoop » Sun Apr 26, 2020 5:16 pm

Is the installer 4.0.104 installed as administrator ( Right mouse click ) as well ?
Joop NL2000team

ridgeandgable
Newbie
Newbie
Posts: 3
Joined: Sun Apr 26, 2020 3:26 pm

Re: Installer unable to install libraries etc.

Post by ridgeandgable » Sun Apr 26, 2020 5:50 pm

Yeah, all installed as Admin

It seems to be running though in p3d

User avatar
phjoop
NL2000 Development Team
NL2000 Development Team
Posts: 1402
Joined: Thu Jan 01, 1970 2:00 am
Location: Leek

Re: Installer unable to install libraries etc.

Post by phjoop » Mon Apr 27, 2020 9:26 am

"Unable to modify fs\Autogen\default.xml is almost allways an administrator run problem.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest